WordPress not sending emails anymore

(marcos.zy) #1

Hello there! :slight_smile:

So, the story is a little long. Any help would be very much appreciated!

I had a blog on CloudWays, and it was sending emails normally, when someone post comments, etc.

The blog gone offline, I cancelled my server. A few weeks later, I decided to put it online again. I’ve signed up for another Cloudways server, and put everything online.

Now, the blog is not sending emails anymore, whenever someone posts a comment. No emails warning me, the administrator, no emails from the plugin “subscribe to comments”, etc. No emails in geral from the WordPress blog.

The technical support said me that WordPress sent emails through PHP, and this could be blocked. They asked me to install the SMTP addon. But, does this make sense?

Sorry, I didn’t understand very well. And, well, how will I configure the SMTP addon inside my WordPress?


Unless you have an addon to send out these emails, your emails will not go out. You have a couple of options:

  1. Install a plugin within wordpress that sends out SMTP.
  2. Configure SMTP from your cloudways server options, and use a 3rd party solution such as mailgun or use the elastic email addon.

(marcos.zy) #3

Thank you very much. But, this was working properly at CloudWays, before, in other server. It has stopped in the new server.

WordPress is not sending emails anymore. That emails when someone posts something, warning the admin, for example. Do you think I need to use the CloudWays free SMTP addon? But, what will be the changes inside WP?


You had some sort of mailsend installed before, even if you did know about it.

Try using elasticmail, seems to work for most people around here.

(marcos.zy) #5

But, does people use Elasticmail with WordPress? I’m just wondering how to configure that.

Well, accordingly to CloudWays, before my WordPress was sending emails through php. This I didn’t understand very well.

(Talonwp) #6

I had a similar case @marcos.zy, my contact forms stopped working after I cloned the site and transferred it from DigitalOcean another server Vultr.

I couldn’t work out the details so I contacted the support, they said first my WordPress was using its internal php mail function to send email. but now I will need to activate SMTP and redirected me to this KB: https://support.cloudways.com/how-to-activate-the-smtp-add-on/

It is fairly easy to setup SMTP.

(marcos.zy) #7

I’ll try that, Talon. :slight_smile:

(Dan) #8

When I moved to Vultr I also had a problem with emails not sending. I assume that has to do with specific server-side settings. And I could not solve the issue with most SMTP plugins that I tried.

What i DID find that worked perfectly for my WP + WooCommerce setup is the Mailgun service (which is free to use for most small accounts like mine) which had to be properly setup on the Mailgun site, as well as in the WP Mailgun plugin setting, PLUS including entering the Mailgun info in the SMTP settings within Cloudways.

But once all 3 were setup I have a fast and free solution that is rock solid and reliable.


I second Mailgun. Totally rocks. Once you’re all setup, you will need to ask them to remove the 100 emails/hour restrictions they put on all accounts at first. Just contact support and they will do it for you.

(marcos.zy) #10

Hey guys,

Using Mailgun I don’t need to enable a SMTP addon at Cloudways?

(Mustaasam Saleem) #11

Hi @marcos.zy

If Mailgun is set-up on your WordPress site, then you don’t need the SMTP addon at Cloudways.

(Luis Izquierdo) #12

I have the same issue. Coincidentally it started when i switched from Digital Ocean to Vultr. Support sent me some error logs. I traced the issue to a server side issue where the server is attempting to send the emails using IPv6 when they should be using IPv4. I will try the Mailgun workaround to see if that works, but in cases like mine where i manage numerous apps, it is a major inconvenience having to setup Mailgun on all my apps.