Switch to Barracuda File Format

Hello

I am trying to install Moodle on Cloudways but I am stuck in the server checks section

This is what I have to fix

Your database uses Antelope as the file format. Full UTF-8 support in MySQL and MariaDB requires the Barracuda file format. Please switch to the Barracuda file format

For full support of UTF-8 both MySQL and MariaDB require you to change your MySQL setting ‘innodb_large_prefix’ to ‘ON’

Can you help me with this?

It seems that I can do this at runtime. SET GLOBAL innodb_file_format = “Barracuda”; SET GLOBAL innodb_file_format_max = “Barracuda”; SET GLOBAL innodb_file_per_table = “ON”; SET GLOBAL innodb_strict_mode = “ON”;

and

ALTER TABLE <table_name> row_format=compressed;

What are the implications? Can I really do this at runtime? Are there any pitfalls that I must be aware of?


Lewis