Still getting far too many "503 Backend fetch" errors?


#1

I know there are a few posts out there about “503 Backend fetch” errors but I’m no further forward as to what’s causing them and how to resolve them. I’m seeing them on every Wordpress site I host with Cloudways but some sites more than others. One site in particular seems to have more than any other - so much so that Google Search Console is starting to report them. The errors seem to be more prevalent when someone uses a browser back button but there’s nothing consistent about it as far as I can tell?

I have tried various Breeze and Varnish settings, all to no avail and I really need to get this fixed or find an alternative hosting solution.

Thanks in advance for any thoughts or suggestions.


#2

Try increasing Execution limit from 60 to 150 on the server.

If that doe not work, turn off Varnish.


#3

If all your sites are doing this, you have something incorrectly configured. As mentioned, check Exec time. Be sure server mem is high enough for your needs, plus its adjusted in wp config properly.
Changing hosting would not be a solution.


#4

Would be nice to see Official Support show up and answer these questions. Just sayin…


#5

Agreed! Well, I’ve been monitoring the situation closely on one particular site where the issue seems most common. I have adjusted the exec time, checked and increased server memory as well as switching varnish on and off. One major thing I did find that disabling the Breeze plugin completely, the issue remained.

If there’s one action that’s likely to cause a 503 error more than any other, it’s doing something in WP Admin such as editing a post or page and then using “view site” or “view page” but even then, it’s not consistently failing.

I then used the Cloudways migrator plugin to clone the site. The issue remained on the new, cloned site. I am scratching my head!


#6

Yes, I am unable to replicate the error on demand…it seems to happen randomly. I noticed it more when in the backend also when pressing back.


#7

I tend to receive this issue as well. Increasing Exec Limit via services did not really resolve this until I have spoken to Cloudways Technician. Quite few people are receiving this, maybe make a blog about optimizing WP installs etc better to prevent this issue?


#8

Did you get a solution? If so, can you post it. I would like to know what is causing this and how to stop it. Of course we can turn off Varnish, but that seems counter-productive.

Anyone know how to fix this?


#9

I’ve still had the problem with Varnish turned off. I’ve come to the conclusion that it’s related to overall server performance and loading, even though all of my stats indicate light loading in every respect. I am also wondering if somehow it’s related to database activity as the most common occurrence for me seems to be immediately after editing a post, page or whatever in WP…


#10

You get this error with Varnish off? Thats really odd.


#11

I dont want to open a ticket every time this happens. I just want a fix so I can do it myself if possible.


#12

One thing I have discovered is that it happens also on a brand new “vanilla out of the box” Wordpress install. None of the clues seem to add up though.


#13

Also encountering this issue, and it’s too random to nail down to a specific cause/effect. We really need a Cloudways engineer in here to address this. I’ve flagged the conversation - we’ll see what happens.

Paul


#14

Anyone with Cloudways want to help us?


#15

Hi All,

This is not a generic issue as anything could be causing this error. It is suggested to create separate support tickets so that our support team can replicate each scenario to address the issue under discussion and possible identify the root cause of it.

Regards,
Ibad ur Rehman


#16

Same here, random 503 varnish errors across all CloudWays servers and apps (have 8 total servers, about 20 apps, Wordpress and Laravel). Impossible to reproduce on command, very frustrating. Causes Redis Jobs to fail too.