SSL Certificate doesn't match name


#1

I have two different applications on the same server. Last week I added a Let’s Encrypt SSL to one of them. Now I’m trying to add another Let’s Encrypt SSL to the other application. It looks like it’s successfully created in Cloudways, but when I go to the site it shows the SSL certificate for the first application and I get a warning about the cert not matching the name of the site.

Am I doing something wrong? I’ve tried restarting the server and purging the cache.

Note: I’ve sort of been able to get around this by going to the first application and adding the domain for the second application there.


#2

Hello @thomasrdailey,

Usually, integrating SSL is pretty straightforward. Your way of adding SSL seems correct but could you share more details on the type of warning you were getting?

I assume that you mapped the domain first for both of your sites and then integrated SSL for that domain.

Regards,
Ibad Rehman


#3

Thanks, support fixed it for me. Not sure if they did anything or what though.