[Solved] Varnish Cache not caching? it's the Google Analytics cookie

If you see a long (> 0.5 or 1 s) Time To First Byte probably your html is not cached.

You can become sure about that by looking to the response header: Image%20121

This may happen because of Varnish Cookie Policy: «Varnish will, in the default configuration, not cache a object coming from the backend with a Set-Cookie header present. Also, if the client sends a Cookie header, Varnish will bypass the cache and go directly to the backend.

This can be overly conservative. A lot of sites use Google Analytics (GA) to analyze their traffic. GA sets a cookie to track you. This cookie is used by the client side javascript and is therefore of no interest to the server.»

I had this problem also with the frontend.

To solve it was enogh to go to: “APPLICATION SETTINGS” => “VARNISH SETTINGS”

The other image:

Are you saying we should exclude or include the _ga cookie in the Varnish settings?

To include it. I see no reason to avoid caching just because the user has the _ga cookie

But if you add the GA cookie to the varnish settings you actually Exclude the cookie from being cached and also the page that cookie is on? So should the cookie be excluded from varnish in the exclude settings?

What rule did you put in place to solve this issue?

jon2 put _ga in varnish setting (include cookies)

Hello Hyperreview, After including the GA cookie to varnish cache the cache hit missing issue is solved, But after that whenever i try to login to the site in say " ERROR : cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."

But i if clear my browser i can login to my site but if i move to another tab in my browser it instantly get log out again. And if i again want to login i had to clear my browser again! How to solve this?