SEO and Cloudways CDN - Google Not Indexing Images


#1

Google isn’t indexing our 4,000+ images. How do we set up Cloudways CDN to correct this?


#2

Adding a bit more information here: It looks like our sitemap tells Google the images are on our site and, of course, they are all cached on StackPath’s CDN. So, I think it shows duplicate content as well as not aligning with the sitemap.

Any help or guidance would be very much appreciated.


#3

What are you using to generate your sitemap? Sounds like the problem would be there.


#4

We’re using the All In One SEO plugin. The sitemap looks good pointing to the images on our site. The problem is, they’re cached on StackPath using a different URL. There doesn’t appear to be a setting in Breeze to address this.


#5

That’s because the issue is how AIO SEO is designed. It’s a poor choice. I personally like SmartCrawl from WPMU but another one to try which may not have that issue is Yoast. You need to use something that will actually crawl your site to get correct URLs and not assume based on local directory listings like AIO SEO does.


#6

Thanks. I’m happy to try another plugin but I’m still a bit confused. AIO SEO generates a sitemap that is correct. The images are duplicated on StackPath with a different URL and there doesn’t seem to be a way to tell Google this.