Issue with Database table permission (Site down)

suddenly my DB stop working and it can’t be restart again from cloudways admin panel.
Cloudways support was fixed it, but there was some permissions errors, just after i tried to update one of my plugins, the site went down.
i got this errors on safe mode:
Table ‘wp_actionscheduler_actions’ is read only in
on the support i been told to contact the plugin vendor, which absolutely have nothing to do with my DB permission.

after open a ticket i got this:
We have checked your application database and after analysis, we have found some corrupted tables kvmhrhujxh.wp_yoast_indexable which may also be the reason you are getting those errors on your application logs. So after trying to repair it shows that your application is using an INNODB type table and to repair those you may need to convert those to MyISAM I am sharing the StackOverflow link with you: https://stackoverflow.com/questions/5348703/the-storage-engine-for-the-table-doesnt-support-repair

but… again … i have on permission the edit or repair my own DB from cloudways admin panel.
so i replay this and still got no answer :
"i have tried to repair one of the using INNODB tables, by using
ALTER TABLE table_name ENGINE=MyISAM;
as you guide me, and i got this error:
Error in query (1036): Table ‘wp_actionscheduler_actions’ is read only

https://stackoverflow.com/questions/17629407/mysql-error-1036-table-is-read-only"

any idea what can i do?