How to get my google domain name to point to the server here

(Tannie Duong) #1

Hi, I’m on trial with Cloudways, and trying to determine if it’s worth it to use. So far, I’m on the fence. i’m having trouble mapping my domain name to the Cloudways server. It was really easy to do with Siteground. I bought my domain name from Google Domains, I did the whole A record in the DNS settings, and my website is still not up yet. Wondering if there’s someone who has trouble using google domains with Cloudways has got it to work?

(Gulshan Kumar) #2

Assuming, you are using Google Domains and its default nameservers.

Okay, next at your DNS manager you need to set below two records

@  ------------> A -----------> Cloudways Server IP Address 

wwww ----------> CNAME ------>

It may take few hours to reflect changes, you may keep eye on DNS Propagation status via dnschecker website. Ref:

(Mustaasam Saleem) #3


Thanks for trying out Cloudways services.

Here is an extensive guide to point the domain on Cloudways server.

Let me cut it short, here are the things you may require:

www – use it when you want to point a domain (ex: to the IP address.
A Record | www | 188.166.XXX.31

@ – use it when you want to point a root domain (ex: to the IP address.
A Record | @ | 188.166.XXX.31

[any subdomain] – you can use any name of a subdomain (ex: that you want to point to the IP address.
A Record | dev | 188.166.XXX.31

It may take up to 48 hours for DNS propagation. Keep checking via here is an example.


(Tannie Duong) #4

Thanks for the snapshot – it sort of confirms what I did have.

For my CNAME I directed it to the URL for the application I just made with Cloudways, so:

The only problem is, now its coming up as an insecure connection. I am getting this error: Error code: SSL_ERROR_BAD_CERT_DOMAIN

Can someone direct me to a page that helps me resolve this now? Lol…

(Tannie Duong) #5

Actually, I found out that I needed to use your free SSL certification for each of the url domains.

The problem is now that and just putting in takes me to 2 completely different sites. Not sure why I am being lead to Cloudway’s default website settings I had in the ftp folder when I go to https//…?

(Mustaasam Saleem) #6

I would suggest sticking with one domain only, either www or non-www and redirect the other one.
I have written an extensive guide on adding SSL certificate to a WordPress site. Would encourage if you can give it a read and make sure everything is configured properly.

(Gulshan Kumar) #7

If you are getting redirected to default address, most commonly there are two reasons for it

  • Either you have not update domain at Application
  • Or, you need to purge once Varnish Cache.

Hopefully, it should resolve the issue. It’s not a big problem.

To fix, you can install Let’s Encrypt SSL from Application Section.