Draft Save or Publish Error


#1

Hi Guys. We started experiencing something on a new website we are developing today, where we cannot save a page as a draft or publish any changes as they are simply disregarded and if we click on the page to edit it no changes were saved.

There was nothing that changed that we were aware of like a plugin installed or updated or a Wordpress update. Some are saying that a security plugin could be blocking the REST.API which is used in the saving of pages and posts.

We have tried all the online troubleshooting but cannot get to the bottom of this problem.

Any ideas?

Thanks,
Gareth.


#2

Have you tried resetting permissions in the App?

Whenever we have an issue of something not working - e.g. plugin not updating or something not writing to the database, we reset permissions.

Can also be that the site is out of database storage space, but that’s very unlikely if it’s a brand new site on a new app.


#3

How do I reset the user permissions?


#4

Hi I managed to sort out the problem and it works correctly now. It had nothing to do with permissions as it was doing the same for all users working on the website.

I installed an SSL certificate on the app and we are now doing the development over https:// and it saves correctly without any problems.

Maybe this will help future users if they have a similar issue.

Thanks.


#5

Thank you @gareth1 for sharing the solution.