Configuring Elastic email

Is there a configuration step I have missed or something I should have done differently?

I’m new to Cloudways and have just added the elastic email add on and enabled it as the smtp for the server. I have not added any settings to the gmail account being used by the server.

All the emails are being sent to directly to spam folders and flagged by gmail as potential problems. On password reset there is a big red banner saying "This message seems dangerous It contains a suspicious link that was used to steal people’s personal information. Avoid clicking links or replying with personal information.“Other emails are marked with a large yellow banner saying " Be careful with this message Gmail could not verify that it actually came from xxxxxxxxxx@gmail.com. Avoid clicking links, downloading attachments or replying with personal information. Report phishing”
I’ve deleted my actual email address from message above.

Only Google’s servers can send email “From” gmail.com, so the mailservers of people who receive the messages see that an IP not belonging to Google is reporting that the sender is gmail.com and they mark the message as suspicious.
The recipient’s email reader then displays its own warning that the message has an unauthorized sending origin and thus “This message seems dangerous…”

There’s nothing specifically bad about your message – given the proper sending credentials, it would arrive without incident. You simply cannot send email “From” gmail.com if you’re not Google.

If you want to send from your Gmail address, you need to use an authenticated outbound SMTP setup:
Google: Cloudways Activate SMTP Addon
Google: Siteground Google Free SMTP Server

1 Like

@LucasPelton has provided a detailed answer to your question.

You need to set up SMTP server if you wish to connect your Gmail account.

Please refer to the following guides for assistance:

How to activate SMTP Addon?
Configure Gmail SMTP on Cloudways

Regards,
Ibad

Thanks for your detailed reply.
I’m still a bit confused about all of this though.

  • Is setting up an smtp addon an alternative to elastic email?
  • If so, should I abandon elastic email altogether?
  • Is there a way to configure elastic email so the messages are not red flagged when received?

I have already set up txt records on my dns with the settings advised by Cloudways support. (“v=spf1 MX include:_spf.elasticemail.com include:emailsrvr.com ~all”)

Is setting up an smtp addon an alternative to elastic email?
Yes. You would choose “Your Own SMTP” on this screen:

If so, should I abandon elastic email altogether?
Elastic Mail is simply an SMTP provider that’s pre-configured to work on the CW sever at the server level. If you choose “Your Own SMTP”, Elastic will by necessity be UN-selected.

Is there a way to configure elastic email so the messages are not red flagged when received?
If you want the “From” address to be xxx@gmail.com, you can ONLY use Google’s mail servers (setup explained in the article from ibad.rehman: https://support.cloudways.com/configure-gmail-smtp/). You can’t send “From” gmail.com using anybody else’s SMTP server.

Depending on how many tenants you have on your server (and if they’re WordPress) you may want to consider an SMTP addon at the application level, rather than the server level. There’s a great WP plugin called Post SMTP that I’ve had great luck with: https://wordpress.org/plugins/post-smtp/

Post SMTP also has a built-in connection to set up to use Google’s mail servers. In this case, you’d want to install turn off all server-level SMTP settings and just use the plugin per-application.

Setting your SPF record to “v=spf1 MX include:_spf.elasticemail.com include:emailsrvr.com ~all” will only allow you to send through Elastic servers “From” whatever domain has that record.

1 Like

Firstly - the effort you have put in to helping a newbie such as myself is breathtaking, thank you.

However, after trying to follow your advice I am still having problems.

  1. I deactivated elastic email and installed my own smtp on the server, using the rackspace details
  2. I installed and setup post smtp on the application, using my rackspace email details.
  3. A test email using the Wordpress password reset showed the email originating from my personal gmail address not the rackspace email address - with the corresponding warning banner.
  4. I changed the general settings on the Wordpress installation to show my rackspace email address and not my personal gmail address
  5. Another test email using the Wordpress password reset again showed the email originating from my personal gmail address not the rackspace email address - with the corresponding warning banner.

I’m not bothered which system, I just want to setup my email so users don’t get warning messages. Not sure what to try now.

You’re welcome! The only way to not be a noob is to a) learn it all yourself or b) get some help. I’m happy to help.

First: You’ll only need Post SMTP, not the server-level SMTP addon.

Now, ake sure you have the “Message” tab filled out as below:

This will ensure that the message is “From” the rackspace address when from WP.

Once you’ve confirmed that the message is “From” the right address, you’ll want to publish/update SPF records in your sendingdomain.com DNS indicating that Rackspace is a legit sender for the “From” address.

1 Like

It’s all working as it should now - you’re a star, thanks.:+1:
I had the message set out with the rackspace email address but what seems to have made the difference is ticking the boxes prventing plugins and themes from making changes.