Cloudways Wordpress Multisite Domain Problem


#1

I like how fast was to setup MU in Cloudways, setup subsites with subdomains was easy and worked as expected. however I spent many hours trying to figure out why switching to domains wasn´t working. As of 4.5 MU doesn’t need domain mapping plugin, but I was reading people are having troubles getting their domains mapped properly.
The issue was that I was able to access https://mydomain.com but I wasn’t able to access the dashboard, https://mydomain.com/wp-admin all i was getting was a 404. Support couldn’t get it to work either. So I try new install, but this time instead of setting up the network with subdomains I did with subdirectories. It worked switching to domains this time. for some reason within cloudways (i’m using digital ocean) subdomain MU setups don’t work, you have to use subdrectories.
just wanted to share my experience, cos it took me some time to figure out.


#2

Hello @web.biker,

In order to set up sub-domains correctly, you need to define subdomains inside your WordPress MU setup as well as inside Additional Domains section on your Cloudways platform inside Domain Management tab.

Please go through the details guide on setting up WordPress Multisite.

Feel free to contact me if you still face any issues.

Regards,
Ibad Rehman
Community Manager