Clone Site Url is Redirecting to Live Site

(Fsalim) #1


My cloned site is redirecting to the Live site.
I asked help from Cloudways and they looked into it saying "Your WP_OPTIONS table is hard corded with your domain and there are few tables that are showing your actual site URL instead of your cloned application"
I need replace the domain url to the clone url. Can someone instruct me on how I can do this?

Is there an mySQL command I can run?

(Mustaasam Saleem) #2

Hi @f.salim4

Have you tried replacing the URLs from WordPress Dashboard?

I hope this will help you out. If not, you may need to change values directly from the database.
Find the table WP_OPTIONS in your database. Replace option_value of the siteurl and home with the cloned URL of your site.

You can now visit the dashboard of the cloned site, go to Settings and then select Permalinks and change it as per your desire.

(Fsalim) #3

As per your first suggestion, I can’t access the wp-admin since it redirects.
For the 2nd suggestion, the new URLs were already set for siteurl and home.

Let me know if you have any more ideas.


(airquality associates) #4

I’m also observing this issue; did you find any resolution?

(Info) #5

I ran into this issue multiple times. Live support fixed it and told me it came from the app’s cache:

You can delete cache folder inside wp-content of cloned app and restart all services from Server > Manage Services

I have not tried this myself yet, but it might be worth giving it a shot.