Breeze & WooCommerce Caching Issue?


#1

Dear all,

Wordpress 4.9.1
WooCommerce 3.2.6
Breeze 1.08

I’ve seen a few posts relating to this issue but I’m looking for a definite solution. The issue must be related to caching - when a customer selects a product in WooCommerce the Quantity option, instead of saying ‘1’ may say 4 or 5 or 6 or … 10 depending upon how many others have visited the product! I have caching switched off right now but, obviously, that’s not ideal so I’m looking for the absolute settings in Breeze, including exceptions etc.

Thanks in advance.


#2

I should add that I’m also getting some '503 Backend fetch errors but there seems to be no consistancy to this.


#3

What install did you choose on Cloudways when you setup the app? WordPress or WordPress with Woocommerce?

Do you have varnish installed?


#4

Hi @nigel.grass

As asked by @nicksanderos what did you select while setting up the WordPress? Was it a simple WordPress or WordPress with WooCommerce?


#5

Sorry for the delay. It was a site I imported myself onto a 'php stack" instance then added Breeze and set up the parameters according to a standard “Wordpress with WooCommerce” instance - which seems pretty vanilla.

Varnish is enabled but no rules are set.


#6

Yeah, there are a few “under the hood” things with the woocommerce install on Cloudways: needed to block caching certain elements. Because it’s a self-import those addons won’t be there.

If you head to this thread and add in the exclusions (pages and cookies): List of WooCommerce cookies to exlude from Varnish?

Clear cache and flush varnish, and then test everything. (If you have Cloudflare then obv. flush that cache too.)


#7

Yeah thanks, Nick, I’ll do that but I’m pretty sure an out of the box WP/WooCommerce instance doesn’t have these exclusions set - I created one thinking “If I just replicate whatever settings then all will be well”.