Breeze is not working, was working on www but not non-www site version


#1

Hi, I’m just newly migrated and have set up Breeze and the Cloudways CDN. I have ticked the option to fix something called “expires headers” but when I test it in Pingdom tools I still get errors, depending on which url I use to access my site:

My site has four versions (I have edited spaces into the links here so it would allow me to post and does not think I’m spamming)
https:// heatherwatts . com – (“expires header” error found by Pingdom tools)
https:// www.heatherwatts . com – Breeze works (no “expires header” error found by Pingdom tools)
http:// heatherwatts . com – (“expires header” error found by Pingdom tools)
http:// www.heatherwatts . com – (“expires header” error found by Pingdom tools)

Actually now ALL of them are getting errors. A moment ago at least one was working. Any thoughts? Does anyone know how to fix this or what I might be doing wrong?
Thanks.


#2

Three of those 4 URLs are redirecting to the canonical domain (as they should) Heather. So the only one there’s any point in testing is https://heatherwatts.com/

For some reason, I’m getting a warning that your Let’s Encrypt certificate is for an untrusted provider. I’ve never seen this error before, but the easy first step would be to try revoking the SSL certificate and then recreating it. This error is likely what is confusing Pingdom. It makes a test fail on GTMetrix too.

You can test it here:
https://www.sslshopper.com/ssl-checker.html#hostname=heatherwatts.com

If resetting the SSL doesn’t solve it; you’ll need to create a support ticket with the Cloudways gang.

Hope that helps?

Paul


#3

Thank you very much Paul. That didn’t work so I have contacted support. I really appreciate your help and am glad you caught this! :slight_smile:
Heather