Breeze Group Files Causes jQuery Undefined Error

Hi all,

When I check the box to Group all my JS files together al of a sudden my front end breaks because jQuery is no longer defined.

Everything was working fine before but for the past few days our site was broken and after extensive trouble shooting I discovered this Grouping option was the issue.

How important is this for site speed? Or is it something we can live without?

The thing I am worried about is that it is a symptom of a larger problem.

Thanks for any thoughts on the matter.

Best regards,

Jethro
House of Malt

1 Like

Hello Jethro,

Could you please share the email address you used for registering the account and your site URL? I have spoken to Breeze developers and they need to analyze your site before suggesting any fixes.

You may direct message me your details.

Regards,
Ibad Rehman
Community Manager

Same error here. Can be reproduced on this staging website:
https://wordpress-196329-1021329.cloudwaysapps.com/

It seems that Breeze conflicts with Owl Carousel plugin.

I tried excluding these two files from grouping (Exclude JS option):
/wp-includes/js/jquery/jquery.js?ver=1.12.4
/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1

It made no difference. I tried both with version numbers and with website url. The behavior is the same - Breeze ignores my settings and combines jQuery with other scripts.

How can this be fixed?

The website is down. So, I cannot test it live. However, from my experience, you need to test all the JS files one by one to see which might be the problem. You can add all of the JS files to exclude field and then start removing one by one and see when the website will get broken. Maybe you need to purge cache when you remove a line. Just to be sure.

I’m sorry. I was debugging the issue and it seems that I dropped the staging in the meantime. Here is an updated website:
https://wordpress-196329-1021735.cloudwaysapps.com/

It seems to be non-working. I added both jquery.js into it and it made no difference - breeze still concatenates the jquery.js file. I tried adding


Unfortunately, Breeze seems to ignore this setting and still concatenates jquery. Yes, I tried to purge both Breeze and browser cache (I have “Disable cache” option checked on the Network tab in Developer Tools).

Have you tried to delete the cached/combined files that Breeze create with FTP access? I haven’t seen that problem in Breeze, but I have encountered it in other plugins.

Unfortunately, this cannot be done via FTP. Breeze gives special permissions to these files and thus they cannot be deleted.

I am out of ideas then. Sorry. Maybe support can help you or another member of the community knows more about Breeze than me

1 Like

Hey Ivan,

I have discussed this matter with the expert and he will be getting in touch with you shortly. If you already have created a support ticket for this, kindly share the ticket number with me.

Regards,
Ibad Rehman

No, I haven’t created a support ticket yet. On Breeze’s page on wordpress.org it was suggested to create a topic here.

The issue jQuery undefined error in grouping file will fix in our upcoming releases.