Upgrade PHP and MySQL


#1

I have an old Vultr package which instead of 160GB has 100GB for the same price. So, I was thinking to clone the server to get the newest version of it. During that process, I was also thinking if it would be wise to upgrade the PHP from 7.2 to 7.3 and MySQL from 5.6 to 5.7 (for better performance)

I only have Wordpress applications on the server and I was wondering if anyone has done it and encountered any serious incompatibility. And in general, any suggestions are always welcomed.


#2

Make sure you have WordPress up to date and WP itself will run fine under PHP 7.3 and MySQL 5.7.

Where you could run into problems is with all your plugins. Make sure you check with each plugin you use to make sure they are PHP 7.3 compatible. There is a PHP compatibly checker plugin you can install to help, but it isn’t 100% accurate, so there may be a few plugins you’ll need to investigate further. Also, test all your sites on the cloned server before making them live.


#3

Hey @tasosventouris,

That’s good thinking, However, make sure to backup or better try the changes on a staging site before you apply changes on a production site.

Good luck upgrading!

Ibad Rehman
Community Manager