Twitter Card Images Not Working with CDN


#1

I have noticed that when I have my CDN enabled through Breeze my pages shared through Twitter do not show images in Twitter cards.

Simply put. When I’m not using the CDN for Breeze my content and images show perfectly in twitter cards.

This is a pretty big problem for me, and I’m guessing others.

From some of the posts I’ve found on the subject, it may be an issue of Twitter bots being blocked from the Cloudways CDN.

Does anyone have more information about the problem or a solution?

Some have stated that moving to another CDN or caching plugin solved the problem.


#2

Alright. I believe I figured it out.

The instructions for setting the CDN NAME in Breeze state to the following:

Note: Use double slash ‘//’ at the start of CDN CNAME, if you have some pages on HTTP and some are on HTTPS.

The instructions are to set the beginning of the CDN URL to //.

There’s not much explanation about why the URL should begin with //.

All I did was change my CDN URL to begin with https:// and my twitter cards are fine now.

Example CDN I entered into Breeze:


#3

Thank you for updating us and sharing the solution. I’ll get in touch with Breeze team to add further explanation on the right way of adding the URL.

Regards,
Ibad Rehman