Breeze constantly eating up my server space. 15GB of cached files


#1

Guys,

Hope someone will finally get this sorted. My Breeze installation has been raking up huge cache files. Refer to the screenshots below.

One of your support team members stated that NGINX in your thunderstack is already handling minification, so I should turn it off in Breeze.

This is a gap in understanding confusing me. If NGINX is already handling some functions of Breeze, why is Breeze not turned off? Especially since Breeze is by cloudways too?

This brings to light another recent thread about disabling Gzip / browser cache where one of your staff members “believes” there is enabling or disabling duplicate functions in Breeze will have no impact.

Well, I have one big 15GB impact here. gzip / browser cache / minification may not be directly related, it’s duplication of functions that seems to be causing the problem here.

Get this sorted Cloudways.


#2

Hi @thienkw,

We are checking it and we will update you with the fix. Thanks for reporting.


#3

Glad to hear.

Please note your Grouping of CSS / JS files seems dependent on turning on your minification settings in Breeze.

Please dont throw away grouping as I find it very useful to reduce HTTP request.


#4

Hi @thienkw,

Yes, we have made it that way. Breeze groups only minimized CSS and JS files. It will be trickier to group non-minimized CSS and JS files.

We recommend that you first minimize and check how things work out before grouping them.


#5

What I’m saying is, Wali is telling me to disable minification in Breeze. Without minification, I cannot group my CSS / JS files. So whatever fix you guys intend to do to solve this issue, please dont sacrifice CSS / JS grouping.


#6

Have you run benchmarks with grouping turned on and off? You may find that with HTTP/2 there’s no benefit to fewer requests. It may even slow things down a bit.

I use WP Rocket, and their advise is generally to turn off grouping (although they encourage you to test for yourself).


#7

I’m so glad I ran into this post. I switched from wp-rocket to breeze with no loss of performance but ran out of server disk space a few days ago. The support rep I chatted with cleared it but was pretty vague about the cause just saying it was “server cache files”. Never had this issue with wp-rocket.
I do love the performance of Breeze but for one WordPress site to fill my entire servers disk… Yikes


#8

And it’s gonna fill up again unless you turn off minification of CSS/JS in your breeze settings. Or Cloudways issues a fix.


#9

Yes I’ve tried. Makes a difference for me.

I have lots of small gallery images loading on my woocommerce product pages. I rather have HTTP/2 busy serving the small gallery images than to have it serving JS / CSS files.


#10

isn’t Breeze has an auto purge function? just below the Select button to activate the cache.


#11

Yep. That didnt work too. It has always been at the default 1440.


#12

For the time being you turn that feature off and use the plugin Autoptimize.


#13

@ahsan.parwez, any update on fixing this issue?


#14

Hi @thienkw

Breeze 1.0.7 has been launched in which there is an update for this fix.